PayByPhone Incident
Incident Report for PayByPhone
Resolved
This incident has been resolved.
Posted Mar 01, 2024 - 05:22 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 01, 2024 - 05:17 PST
Update
We are continuing to work on resolving the issue. Thank you for your patience during this time.
Posted Mar 01, 2024 - 04:46 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 01, 2024 - 03:29 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 01, 2024 - 03:21 PST
Investigating
Attention PayByPhone Clients,

We are investigating an incident and are working diligently to restore service as quickly as possible.
We appreciate your continued patience.
Posted Mar 01, 2024 - 03:00 PST
This incident affected: North America (PayByPhone Mobile Payment Service), Germany (PayByPhone Mobile Payment Service), France (PayByPhone Mobile Payment Service), Switzerland (PayByPhone Mobile Payment Service), UK (PayByPhone Mobile Payment Service), Italy (PayByPhone Mobile Payment Service), and PayByPhone Mobile Payment Service.