Major Outage Under Investigation
Incident Report for PayByPhone
Resolved
Attention PayByPhone Operators,

Service has now been fully restored as of 8.40am PST / 11.40am EST / 5.40pm CEST.
Posted Oct 06, 2023 - 08:41 PDT
Investigating
Attention PayByPhone Clients,

We are investigating an incident and are working diligently to restore service as quickly as possible.
We appreciate your continued patience.
Posted Oct 06, 2023 - 08:07 PDT
This incident affected: North America (PayByPhone Mobile Payment Service), Germany (PayByPhone Mobile Payment Service), France (PayByPhone Mobile Payment Service), Switzerland (PayByPhone Mobile Payment Service), UK (PayByPhone Mobile Payment Service), Italy (PayByPhone Mobile Payment Service), and PayByPhone Mobile Payment Service.