PayByPhone service issue
Incident Report for PayByPhone
Resolved
Attention PayByPhone Operators,

Service has now been fully restored as of 00:36 PST / 3:36 PST
Posted Mar 07, 2023 - 00:37 PST
Update
We are continue to investigate the issue. We will provide another update in 30 minutes.
Posted Mar 07, 2023 - 00:17 PST
Investigating
Attention PayByPhone Clients,

We have received reports that users may be logged off sporadically. This outage began at approximately at 23:02 PST / 2:02 EST.

We are aware of this issue and are working diligently on recovering service.

We will also provide you with another update within 30 minutes. OR We will provide you with an email confirmation when the issue is resolved.
Posted Mar 07, 2023 - 00:02 PST
This incident affected: PayByPhone Mobile Payment Service.