Full Outage Identified
Incident Report for PayByPhone
Resolved
This incident has been resolved.
Posted May 19, 2023 - 07:21 PDT
Update
Attention PayByPhone Clients,

The platform outage is still ongoing. We now have a good understanding of the cause and our teams are actively working to resolve it. We will provide you with another update within 15 minutes.
Posted May 19, 2023 - 07:06 PDT
Identified
Attention PayByPhone Clients,

PayByPhone is currently experiencing a full platform outage affecting all parking operations. During the outage most end users will be unable to use the platform to pay for parking.

We are aware of this issue and are working diligently on recovering service.

We will provide you with another update via email as soon as possible.
Posted May 19, 2023 - 06:37 PDT
This incident affected: PayByPhone Mobile Payment Service.