Email delivery issues
Incident Report for PayByPhone
Resolved
This incident has been resolved.
Posted Aug 30, 2023 - 16:22 PDT
Identified
Attention PayByPhone Clients,

PayByPhone is currently experiencing an incident. Users are currently unable to receive emails from PayByPhone.

We are aware of this issue and are working diligently on recovering service. All other PayByPhone capabilities remain fully operational.

We will provide you with another update as soon as possible.
Posted Aug 30, 2023 - 16:02 PDT
This incident affected: North America (PayByPhone Mobile Payment Service), Germany (PayByPhone Mobile Payment Service), France (PayByPhone Mobile Payment Service), Switzerland (PayByPhone Mobile Payment Service), UK (PayByPhone Mobile Payment Service), and PayByPhone Mobile Payment Service.