High decline rate for CreditCall alerts. Miami decline rate alerts.

Incident Report for PayByPhone

Resolved

Attention PayByPhone Operators,

Service has now been fully restored as of 00:16 PST, 03:16 EST.
Posted Oct 31, 2025 - 00:29 PDT

Update

Our vendor has identified an issue impacting Fiserv transaction processing and settlement. The appropriate parties have been informed and are working to resolve.
Posted Oct 30, 2025 - 23:06 PDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 30, 2025 - 22:04 PDT

Identified

We are experiencing increased payment declines with one of our payment gateway partners in North America. Our vendor is aware and currently remediating the issue.
Posted Oct 30, 2025 - 21:49 PDT
This incident affected: North America (PayByPhone Mobile Payment Service), Germany (PayByPhone Mobile Payment Service), France (PayByPhone Mobile Payment Service), Switzerland (PayByPhone Mobile Payment Service), UK (PayByPhone Mobile Payment Service), Italy (PayByPhone Mobile Payment Service), and PayByPhone Mobile Payment Service.