Full platform outage
Incident Report for PayByPhone
Resolved
Attention PayByPhone Operators,

Service has now been fully restored as of 7:00 AM PST, 10:00 AM EST.
Posted Jun 09, 2021 - 07:02 PDT
Monitoring
Attention PayByPhone Clients,

We have taken corrective action to resolve the ongoing service interruption and are monitoring the results. We will update this page and send out an email with more details once the effects of these changes are verified.
Posted Jun 09, 2021 - 06:49 PDT
Investigating
We are currently investigating this issue.
Posted Jun 09, 2021 - 06:18 PDT